WordPress Update: Wartungsmodus schaltet nicht ab

Problem:

Nach dem WordPress-Update schaltet der Wartungsmodus nicht ab. Sowohl beim Zugriff auf das Blog-Frontend, als auch beim Adminbereich erscheint die Fehlermeldung:

Wartungsmodus:

Für kurze Zeit nicht verfügbar, um eine regelmäßige Instandhaltung durchzuführen. Prüfe in einer Minute erneut.

Ursache:

Beim Update wird WordPress automatisch in den Wartungsmodus versetzt. Der Wartungsmodus wird deaktiviert, sobald das Update erfolgreich eingespielt ist, oder WordPress einen Fehler feststellt und das Update abbricht. Leider gibt es immer mal wieder Ausnahmen, bei denen ein Update fehlschlägt und WordPress dies nicht registriert. Beispielsweise wenn mitten im Update-Vorgang der Server für kurze Zeit nicht erreichbar ist. In diesem Fall bleibt der Wartungsmodus leider aktiviert.

Lösung:

Der Wartungsmodus muss manuell beendet werden. Dies ist schnell erledigt:

  1. Per FTP in das WordPress-Hauptverzeichnis gehen
  2. Die Datei ".maintenance" suchen
  3. Die Datei löschen

Damit ist der Wartungsmodus wieder ausgeschaltet.

Hinweis:

Manche FTP-Programme wie Filezilla zeigen die ".maintenance" nicht an. Falls dies der Fall ist, unter den Optionen des FTP-Programms bzw. unter "Ansicht" eine Einstellung wie "Alle Dateien anzeigen" suchen und aktivieren.

Autor

Über den Autor: Tobias Genge

Tobias T. Genge ist gelernter Informatikkaufmann und studierte Wirtschaftsinformatik an der FOM Hamburg. Seit 2007 beschäftigt er sich mit WordPress und gründete 2011 mit Fehler7 eine der ersten rein auf WordPress spezialisierten Agenturen in Deutschland.

WordPress Premium Support

2 Gedanken zu „WordPress Update: Wartungsmodus schaltet nicht ab

  1. Hallo Zusammen,

    hatte das Problem, das WP im Wartungsmodus hängengeblieben ist.
    habe die .maintenance Datei gelöscht, Ergebnis ist eine weiße Seite ohne irgendwelchen Inhalt.
    Wer hat eine Idee???
    PS: Auch ein Login ist nicht mehr möglich!!!

    Danke an alle.

  2. Ich habe ein anderes Problem:
    Die Webseite ist online, der Wartungsmodus abgeschaltet.
    Es befindet sich aber kein file .mainetnance in der root
    Ein Plugin Maintenence mode wurde benutzt und deinstalliert

    Wenn Ich nun die Seite beispielsweise auf facebook teilen will erscheint:
    Die Website ist im Aufbau
    Die+Website+ist+in+K%C3%BCrze+wieder+erreichbar

    In der wp-activate.php habe ich schon
    define( ‚WP_INSTALLING‘, false );

    eingetragen.
    nichts hilft
    Kann da noch was inder DB stehen ?

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*